AUDIO TROUBLESHOOTING

662 viewsOperating system
0

Please first have a look at the following resources: raspberrypi.org and scphillips.com.

Edited question
0

HIFIBERRY AMP2 COMPATIBILITY

Modify /etc/rs.conf as:

VIDEO_PLAYER=”omxplayer -o alsa:plughw:1 -t off -b –no-osd”

Posted new comment

Thanks to Christian Bechter and Brian Drake.

0

GET VIDEOS’ SOUND OUT OF THE 3.5mm AUDIO PLUG

Omxplayer doesn’t use default alsa setting (which is set by raspi-config).
By default it is in auto mode, which means if HDMI is connected and EDID reports audio support, then it uses HDMI, otherwise headphones.

Adding -o local or -o hdmi to the omxplayer command line in /etc/rs.conf can be used to override this.

Posted new comment

Thanks to Marcus.